Quest 2 Bug - The beasts Lair

Moderators: Game Moderators, Super Moderators

Re: Quest 2 Bug - The beasts Lair

Postby bbhbc10 » Wed Nov 11, 2009 4:02 am

i had the same problem long ago when i tried to do it (also had dial-up back then also)..took all my energy and page never loaded..when i switched to a faster connection, i didn't have the problem anymore but still decided to skip the step anyway.
User avatar
Village idiot
Posts: 589
Joined: Sun Jun 24, 2007 4:53 am
Location: nowhere and everywhere
Game Age: 6-Western
Clan: Troglahoma

Re: Quest 2 Bug - The beasts Lair

Postby Dare2Bare » Tue Dec 15, 2009 7:15 am

I also am facing a similar issue with the facing the beast part, though i lose energy, the page does not show anything, have the bow as well, tried it failing many times still nothing comes on display to hit the monster with the bow maybe, so am stuck on that part now, no hermes to skip it too...

Please do something about these quest bugs, since going ahead takes a lot many days and energy too.

*EDIT* PS: I am on Broadband not slow dial up rest all flash menus and things come up just fine, this takes forever to load though
Thanks in advance

Its Better to Die Fighting! Than Dying to Fight for It!!

Happy Holidays!!
Posts: 6
Joined: Fri Sep 14, 2007 9:30 am
Location: Mumbai, India
Game Age: 3-Egyptian
Character name: Dare2Bare
Clan: Egg Heads

Re: Quest 2 Bug - The beasts Lair

Postby Chris@home » Fri Dec 18, 2009 10:08 am

Please clear your cache and make sure you're using the latest version of Flash Player ( ) and try again!
Last edited by double on Sun Mar 21, 2010 5:15 am, edited 1 time in total.
Reason: archived due to inactivity
Addicted to Waffles
Posts: 1709
Joined: Sun Jul 16, 2006 11:03 am
Clan: Arkansniffs


Return to Age 4 Bugs Archive

Who is online

Users browsing this forum: No registered users and 1 guest